Announcing theme compatibility with WooCommerce 3.9.x

About a week ago WooCommerce 3.9.0 was released, shortly followed by the 3.9.1 fix release. The new version brings updates to the WooCommerce blocks, changes in its minimum requirements, some minor enhancements and a lot of fixes. Let’s see what’s new.

Product blocks

Version 3.9.0 brings the All Products block which gives you the ability to create product listings on any page using the block editor. Filtering and pagination are also available on the block.

Changes in minimum requirements

Following the update nudges added in WooCommerce 3.8.0 for WordPress and PHP minimum versions, the latest version now requires at least PHP 7.0 and WordPress 5.0 to function. Sites running earlier versions will not be able to update to WooCommerce 3.9.0,

Miscellaneous

This version adds a show password button for password fields, similar to the one introduced to WordPress 5.3, it also adds a Payment Gateway API to support pay buttons, for better button setup and customer experience. For more information please check the plugin’s readme.txt file.

CSSIgniter eCommerce themes and WooCommerce 3.9.0

Most of our new eCommerce themes are compatible out of the box with the latest version and require no action on your part, update WooCommerce and you are good to go. However on some themes you might have seen notices regarding usage of out-of-date templates after updating to 3.8, this has been taken care of. We have released updates for all these themes, you can update them using our automated update system or if you prefer to do things manually you can grab the zip files from our downloads section and install them.

Related Articles

2 comments

  1. Balasubramaniam says:

    Just tested ordering on my site. It seems order copy is not sent to customer.

    1. Nik says:

      Hello. This is most likely caused by another plugin interfering with WooCommerce or hosting server setup, the theme is not involved in any way with email delivery.

Leave a Reply

Your email address will not be published.