WooCommerce 2.1 is coming

Dear all,

This message applies only to members using a theme of ours integrated with WooCommerce, namely one of the following:

  • Femme v2.0 or prior
  • Agora v2.0 or prior
  • Intrigue v2.0 or prior
  • UltraSeven v1.0 (no prior versions exist)

and all our VIP themes over at ThemeForest: Muzak, Acoustic and Club88.

If you aren’t using one of the above themes there’s no need to continue reading, but if you are, please read carefully.

WooCommerce 2.1 is about to be released in the following days, it’s a major release (even bigger than the 2.0 release) and there are a couple of things to note:

It’s only compatible with WordPress 3.8+. If you don’t plan on upgrading to WordPress 3.8 please do not upgrade your WooCommerce plugin to 2.1 and do not update your theme to the latest version.
It has some compatibility issues with WooCommerce 2.0.x, thus has some minor issues with the themes.
So, if you are looking to upgrade WooCommerce to the latest version, please note the following:

If you are on WordPress 3.8:

1. If you haven’t made any modifications to your theme, or using a child theme, or the modifications are so minimal that you can copy paste them later:

You should update your theme to its latest version (found here: https://www.cssigniter.com/download as usual). Don’t forget to take a full backup of your files before upgrading! A good backup plugin for WordPress is BackWPUp, or simply download your theme folder via FTP to your local machine.

2. If your theme is heavily modified, you don’t use a child theme, and there’s no way to upgrade without losing your modifications:

In this case you need to follow the following guide (members only) in fixing a couple of issues that may arise (guide will become available once WC2.1 is released, that’s probably tomorrow).

We will be releasing the newer versions of the theme which are 100% compatible with WooCommerce 2.1 in the day following the WooCommerce 2.1 release, so please have that in mind.

The versions you should be looking for that are guaranteed to have no issues with WooCommerce are:

  • Femme v2.1
  • Agora v2.1
  • Intrigue v2.1
  • Ultraseven v1.1
  • Club88 v1.2
  • Acoustic v2.2
  • Muzak v3.3

Please do not hesitate to open a ticket to the respective theme’s forum regarding this update marked as “WC2.1 UPDATE:” in the topic title.

Leave a Reply

Your email address will not be published. Required fields are marked *